
Tabutronic chess board driver 
by Graham O'Neill 

 

1.  Installation 

1.1 Windows 

You must first install the software that comes with the Tabutronic board as this includes the 
USB driver that allows your computer to talk to the board. 

For Fritz and ChessBase my driver is 64 bit, which means it will only run in Fritz version 15 
and above, and ChessBase 13 and above. 

Download and run the setupTAB.exe program and it will lead you through installing the files 
(TAB_DLL.dll and gon-TAB64.dll) for the required programs. The setup program doesn't 
install for LucasChess as the drivers are already included in that program's download. 

For Arena, ChessBase, Fritz and Shredder the setup program will also install programs to 
allow you to select which board to use if you have multiple boards. For example, for Arena 
this is called "Arena eBoard" and will show you the screen: 

 

Which boards are listed depends on which drivers you have installed. The top of the screen 
shows which driver is currently selected (Millennium Chess Link in the above picture). In the 
list you can choose a different driver and then click Load to select it as the current driver. 
The option to Clear Current Driver allows you to revert to the DGT Rabbit Plugin if you have 
that installed for your DGT board. You do not need to install Rabbit for my drivers. 

1.2 Linux 

My program uses Pascal and Qt5 which might not work on your PC initially. If you find that 
the driver doesn't load at all install the Pascal/Qt5 support library by running: 

 Ubuntu/Debian: sudo apt install libqt5pas1 

 Fedora/Mageia: sudo dnf install qt5pas 
 

The only GUI that currently uses my driver is LucasChess and that already has it installed. If 
you want to reload it then you will need the libctab.so file. 

 



GUI File name Probable Location 

LucasChess libtab.so /home/yourname/LucasChessR2/bin/OS/linux/DigitalBoards 

 

You will probably also have to grant your user name access to the serial ports using either 
chmod to grant RW access or by editing the \etc group file with sudo gedit group. 

 

2.  General information 

Sometimes the system won't release the COM port even though my driver has finished and 
this will stop you from reconnecting the board again. In this case the easiest solution is to 
unplug the board's USB connection at the computer and plug it back in again. You can also 
try turning off power management in the Properties of the port in the Ports section of Device 
Manager in Windows (C:\Windows\System32\devmgmt.msc): 

 

My driver screen cannot be closed using the normal close window button as that would leave 
the GUI without the response it is expecting. Normally it will close automatically when you 
complete the required action but if you need to force it to close (perhaps the driver keeps 
failing to talk to the board) then you need to do this by deactivating the board in the GUI. 

My software does not support the Gesture Control that the Tabutronic software provides 
since I do not have the ability to control the GUI to that extent from my driver. 

2.1 Using Bluetooth to connect 

My driver will allow you to connect to your board using Bluetooth if you have the Certabo BT 
Module (updated with the BT_Sentio_Cerno image from the Tabutronic Software web page).  

Since this board uses "classic" Bluetooth rather than BluetoothLE it is necessary to pair the 
board to your PC first. You do this using the normal process of pairing a device, with the 
Tabutronic probably appearing with the device name "raspberrypi". 

For Windows 11 there is a trick to being able to discover the board. In the Windows Settings 
> Bluetooth & devices > Devices screen scroll down to the Device Settings section and 
select "Advanced" for the Discovery type: 

 



Before activating the board in the GUI turn on the BT Module and wait for about a minute for 
it to start. When it is ready it will show the central four LEDs on the board. In my driver the 
connection type should be set to 'Bluetooth' since 'Auto' will only search the serial COM 
ports. Then when you activate the board it will take a further five or six seconds to connect. 
(If it fails to connect it will try for about ten seconds). After that it should operate the same as 
when connected using a cable. 

2.2 Using BluetoothLE to connect 

My driver will allow you to connect to your board using BluetoothLE if you have the Certabo 
BLE Module. 

For BluetoothLE the board does not need pairing to your computer. 

In Windows the BluetoothLE in my driver currently only works in Windows 10 build 
10.0.15063.0 (also known as version 1703) or later. This is from 2017 so any update since 
then will be OK. You will need to install the Microsoft Visual C++ Redistributable; the x86 
version for Arena/LucasChess/Shredder and the x64 version for Fritz/ChessBase. You can 
download these from Microsoft's website (under "Other Tools, Frameworks, and 
Redistributables") https://visualstudio.microsoft.com/downloads/ 
 

 
 

In Linux for BluetoothLE support you need to load: 

 Ubuntu/Debian: sudo apt install libdbus-1-dev 

 Fedora/Mageia: sudo dnf install dbus-devel 
 

2.3 Configuration screen 

The first time you access my DLL file you will be prompted to set some configuration details 
to tell my driver how to connect to and use the board. 

Connection 
The Tabutronic generally works well with the 'Auto' option in Windows so use that most of 
the time unless you are using Bluetooth in which case see the Bluetooth section below. If 
for some reason Auto doesn't seem to work you can specify a particular port. However, 
on Linux the Auto option is slow as it tries to send and receive data from each port so on 
that OS it is better to be specific if you can. 

LED Display 
This specifies when the LEDs on the board will be displayed. Normally they show for your 
moves and the computers, but the response will be slightly faster if you only show the 



LEDs when the computer moves. You can also turn off the LEDs completely, for example 
if you are using the board for a human vs. human game and just want the GUI to record 
the moves. 

Show possible moves 
This option is useful for people learning chess. When you pick up a piece the board will 
show you all the squares that the piece can be moved to. 

LED flash (Moves, Captures) 
The default is to have the LEDs on constantly when displaying the computer's move and 
flashing to highlight captures. You can change this so that the LEDs will flash when 
moves are displayed if that's what you prefer. 

2.4 Making moves 

The Tabutronic does not have piece recognition so sometimes the order of moving the 
pieces is important so that the software understands the move you are making. 

Captures 
It doesn't matter if you lift the moving piece or the captured piece first. 

Castling 
Like all eBoards you must move the king first and then the rook. 

Take backs 
Move the piece for the take back first. If the move being taken back was a capture you 
will then be prompted to replace the piece that was taken. For taking back castling 
moves, move the king first and you will then be prompted to move the rook. 

Promotions 
When the computer promotes a pawn the LEDs will show which piece to promote to. 
When you promote a pawn the computer will flash the LEDs for the RNBQ positions. 
Select the piece to promote to by placing and removing any piece on one of those four 
squares. 

2.5 Setting up positions 

In GUIs that allow you to set up different starting positions, you can access the screen to do 
this by lifting up both kings. You will see something like: 
 

 



 
Place the pieces on the board where you want them and then check that the screen is 
showing them correctly. Because the board doesn't have piece recognition you will see a red 
square and dot where an unidentified piece is located. You can correct this by clicking on the 
pieces to the side of the board and then clicking on the board. If you right-click then the 
piece of the opposite colour will be set. 
 
You must also use the rotation button to set the board orientation (normally white is at the 
bottom) and the swap button to indicate which side has the next move. Press OK when the 
board is ready. 
 
 

3.  Use with Arena 

A problem with Arena is that it never sends actual positions to the driver, so it isn't possible 
to start a game from a position other than the normal starting position. 

3.1 Playing an engine 

In Engines > Manage select the engine you want to play against and in Levels set the time 
control to be used. Select File > New to start a new game. 

Connect the board to your computer, set up the pieces and activate the board using Extras > 
DGT - Chessboard: 

 

The first time you do this you must go to the Options tab of the screen that appears and set 
the details as shown here: 

 

Set up the configuration details in my driver if required. 

You can now make the first move as white, or click Game > Move Now! to make the 
computer play the first move. After that make moves on the board and they will appear on 
the Arena screen. 

If you want to play a new game use File > New again. 

3.2 Different starting positions 

You can start a game (or analysis) from a specific position but you must do it by setting the 
position up using the board. 

Select the engine(s) you want to use and activate the board as normal. You can click 'Setup' 
on my driver's New Game screen or lift up both kings. In Arena select Position > Set-up a 
Position. Follow the instructions given in General Information above to set up the new 
position. 



In the Arena Setup screen make sure the side to move and other indicators are correct and 
click OK. You can now make the first move or make the computer move or start the analysis 
as normal. 

3.3 Take back moves 

If you want to take back a move wait until it is your turn to play and then take back the 
moves you want on the board. The screen in Arena will automatically be updated. When you 
then make your amended move Arena will ask if this is a new variation or if the old moves 
should be overwritten. 

3.4 Analysing a game 

You can either use the Position > Set-up a Position option above to setup the pieces or you 
can make many moves manually and use this to either get to the starting position you want 
or analyse a game. You can also use this method to make Arena record the moves in a 
human vs. human game. 

Having selected the engine and started a new game click on Position > Analyze Now! (or 
click the Analyze button in the Moves window). This will start the engine analyzing the 
position (unless an opening book is selected, in which case nothing will happen until you are 
out of book) and you can makes moves on the board for both white and black. 

If you now want to play the engine from the current position turn off analyze mode. You can 
now make the next move or click Game > Move Now! to make the engine move. 

3.5 Replaying a game 

You can play through the moves of a saved game but unfortunately Arena doesn't send the 
move information to the board, so you need to follow the moves on the screen too. But you 
can still add and analyse variations. Get the board ready for a new game, load the PGN file 
you want and put Arena into Analysis mode. You can now go through the moves using the 
right-arrow key while making the moves on the board. 

 

4.  Use with CB-Emu (Arena) 

CB-Emu is a program by Franz Huber that allows you to play against old chess computers 
on your PC, using ROM emulations of their processors. 

The Setup installation for my driver will load the files into the appropriate folder (<path>\CB-
Emu\MessChess\Arena) and you can then use your eBoard by running the Arena.exe 
program from that folder. 

You can also run Arena directly from the MessChess.exe program but to do this you need to 
edit a file in the CB-Emu\MessChess folder. MessChess defaults to using Winboard rather 
than Arena, so change this by editing GUI.INI using a text editor (like Notepad), not a word 
processor (like Word). Change the first line from 1 to 2: 

 

Please note: The emulations can run quite slowly and some of them have to emulate 
entering moves as if buttons were pressed on the original chess computer. Please be patient 
when making moves on the board! 



5.  Use with Fritz and ChessBase 

5.1 Playing an engine 

Having set up the game details (engine, time etc) you can activate the board from the Board 
tab. For example, in the Easy Game menu: 

 

For PlayChess the option to enable the DGT board is on the Server Settings screen. 

The driver will then load and attempt to connect to the board. Once connected you can make 
the first move or make the engine move using the Move Now button. 

5.2 Different starting positions 

The Fritz and ChessBase programs are written expecting the board to be a DGT, which 
means they expect the board to have piece recognition. You can only set up the position 
using the board: you can try using Home > Setup Position but I found it to be extremely 
unreliable. 

On the board remove both kings to put my driver into Setup mode and follow the instructions 
given in General Information above. 

5.3 Take back moves 

You can take back moves by waiting until it is you turn to move and then taking back the 
computer's last move and then your own move. The LEDs on the board will lead you through 
the sequence of moves. When you want to enter your replacement move just make it on the 
board. Fritz automatically adds this move as a new variation so you will need to right click on 
the variation and select Promote variation to make it the main line. 

5.4 Analysing a game 

To analyse a game or position put Fritz into Infinite Analysis mode and then make a 
sequence of moves from the starting position. You can also use this method to make Fritz 
record the moves in a human vs. human game. 

If you now want to play the engine from the current position turn off analyze mode. You can 
now make the next move or click Move Now to make the engine move. 

5.5 Replaying games 

You can also play through the moves of a saved game. Start a new game and get the board 
ready for white's first move. Put the engine into Analysis mode and then load the game (for 
example using File > Open > Open Database). You will see the moves in the game panel. 
You can now play through the game using the right-arrow key, with the board's LEDs 
showing the moves. You can also arrow through a set of moves and then make them all on 
the board. 

It is possible to enter variations using the board but I have found this to be very unreliable. It 
seems to be safer to enter variation moves using the mouse on the screen while also playing 
the moves on the board. To return to the main line click on the move before your variation 
and my driver will prompt you to replace the pieces (this step doesn't appear to work at all 



using the original DGT Rabbit plugin so it looks like ChessBase never programmed this into 
their software). You can then continue playing through the game or enter another variation. 

 

6.  Use with LucasChess 

In order to use my driver in LucasChess you need to tell the GUI that you have an electronic 
board. This is done through the Options > Configuration screen. Go to the Boards tab and 
select Tabutronic for Digital board. (In the old LucasChess turn on Enable DGT board).  

When using my board I prefer not to have the tutor popup on the screen so in the Engines 
Configuration I normally go to the Tutor tab and turn on Disabled at the beginning of the 
game. 

6.1 Playing an engine 

Use the Play option to select an engine to play against. This will show you a screen where 
you can select the opponent, choose the colour to play, set the time controls, specify a 
starting position and so on. Once you have completed this click the Accept button. 

If you didn't activate the board using the option on the Play screen you can now enable it 
using the button on the menu bar: 

 

Set up the configuration details in my driver if required, and then play the moves on the 
board and they will appear on the screen in LucasChess. 

To start a new game use the Cancel button and then Play again, or use Adjourn to save a 
game for continuation later. 

You can deactivate and activate the board again at any time. 

6.2 Different starting positions 

There are two places where you can set up special positions. One is when using Play 
against an engine (on the Initial moves tab) and the other is in Tools > Create your own 
game > Utilities > Change starting position > Edit starting position. Both will display a screen 
asking for the new position. 

Activate the board and then remove both kings to put my driver into Setup mode. Follow the 
instructions given in General Information above. 

6.3 Take back moves 

You can take back moves by waiting until it is you turn to move and then taking back the 
computer's last move and then your own move. The LEDs on the board will lead you through 
the sequence of moves. When you want to enter your replacement move just make it on the 
board. 

6.4 Analysing a game 

You can play through your own game by using the Tools > Create your own game option. 
Enter the moves you want, including taking back moves. To analyse a move double click on 



it in the move list panel. You can also use this method to make LucasChess record the 
moves in a human vs. human game. 

To enter a variation right-click on the move and use the Append variation button to display 
the variation screen. For this screen you cannot use the board though and must enter the 
moves using the mouse. 

6.5 Replaying games 

You can also play through the moves of a saved game. Start a new game and get the board 
ready for white's first move. Load the game using Tools > PGN > Load PGN file and you will 
see the moves in the game panel. Move to the beginning of the game and enable the board. 
You can now play through the game using the right-arrow key, with the board's LEDs 
showing the moves. You can also arrow through a set of moves and then make them all on 
the board. 

If you want to enter a variation just make a different move from the one in the file and play 
through the moves you want. To return to the main line take back the moves in the variation 
and you can then continue playing through the game. 

6.6 Training with a book 

The option Train > Opening > Training with a book allows you to practise your opening 
repertoire. Load the opening book (a polyglot file with .bin extension) and enable the board. 
You can then make the moves from the book, and if you get a move wrong then the board 
will highlight your error. Use the Reinit button to start again from the beginning. 

 

7.  Use with Shredder 

7.1 Playing an engine 

When you select File > New Game you can select the strength of the opponent or you can 
use Levels to set the strength and time controls. 

To activate the board use Mode > External Board > DGT Board: 

 

Set up the configuration details in my driver if required, and then play the first move as white. 
If you want to play black select Commands > Compute / Switch Sides and the computer will 
make its move. 



To start a new game either select File > New Game or return all the pieces to the starting 
position on the board. Or use File > Edit Position (or the Edit Position button) to set up a new 
starting position. 

As with the other GUIs it is a good idea to deactivate the board before quitting the GUI. 

7.2 Different starting positions 

There are two ways to set up a position to start playing from. Shredder only sends and 
receives piece positions not more detailed game information, so if your position includes 
restricted castling rights even though the king and rooks are in the correct positions then you 
should use the Edit Position method. 

Edit position 
You can use File > Edit Position (or the Edit Position button) to set up a new starting 
position. Make sure the board is activated first as the new position is sent to the board 
when you click OK. You should see the 'New Position' screen in my driver. Then you must 
also check that the correct side to move is indicated on my screen. If not use the button 
on the screen to change it: 

 

Using the board 
On the board remove both kings to put my driver into Setup mode and follow the 
instructions given in General Information above. 

7.3 Take back moves 

If you want to take back a move wait until it is your turn to play and then take back the 
moves you want on the board. The screen in Shredder will automatically be updated. When 
you then make your amended move Shredder will ask if this is a new variation or if the old 
moves should be overwritten. 

Note that with my driver when you take back a move the Shredder clock is also rewound to 
the correct time. This doesn't happen if you play with Shredder on your screen and use the 
Take Back button. 

7.4 Analysing a game 

You can use the Mode > Analysis option to allow you to make multiple moves on the board 
with the engine analysing the positions. You can also make take back moves and create 
new variations, or if you want to continue playing against the engine from the current position 
use Mode > Play against Computer. 

7.5 Replaying a game 

You can play through the moves of a saved game but unfortunately Shredder doesn't send 
the move information to the board, so you need to follow the moves on the screen too. But 
you can still add and analyse variations. Get the board ready for a new game, load the PGN 
file you want using File > Load Game and put Shredder into Analysis mode. You can now go 
through the moves using the right-arrow key while making the moves on the board. 

To enter a variation just make a different move to the one in the game. Unfortunately, to 
return to the main line you need to manually take back the moves in the variation before you 
can then continue the game. 



8.  Use as a UCI or Winboard engine 

For GUIs that don't support the DLL version of my driver I have also created an engine 
version. This can be used in an engine vs engine game to allow you to use your board for 
playing games. Some of the disadvantages of playing like this are: 

Ÿ You are not allowed to take back moves in engine matches 

Ÿ You can't play "rated" games 

Ÿ Opening book options might be limited 

Ÿ Time control options are often limited (it isn't always possible to give one engine more 
time than the other) 

The engine supports both the Winboard and UCI protocols. 

My DLL driver and Winboard engine both use an INI file to store the settings, which gave me 
a choice for the UCI engine. I decided to keep it the same as the other two, so the 
configuration of the driver in UCI mode is controlled by the Config tab of my screen rather 
than the UCI engine configuration in the GUI. 

8.1 Installation 

My Setup program will ask you where to install the engine file. I recommend that you create 
a main folder for holding any of my eBoard engines that you want to load and that when you 
"install" them into each GUI that you link to them from that folder. If you load them separately 
into each GUI you will need to manually copy the files again each time I issue an update. It 
also means that the eBoard will use the same INI file settings across all of the GUIs you use. 

The process of installing the engine into the GUI depends on each GUI, but in general you 
will need to give the engine a name and identify where the EXE file is. 

8.2 Playing an engine 

How you create an engine vs engine match also depends on how the GUI works. You might 
find that some GUIs also start the engine during the match setup in which case my driver 
screen will appear quite early. 

Also, some GUIs don't close the engine when an engine match is finished so you might need 
to either start a different match or use the "Close engine" option in the GUI to close my driver 
screen. 

 

9.  Use with SCIDvsPC 

Although SCIDvsPC uses the UCI engine version of my driver it has been amended to allow 
for take back moves and so on. It is used by adding it as a secondary Analysis engine rather 
than the main engine in a computer vs computer match. 

9.1 Installation 

Having installed the driver file using the Setup program (probably to a common folder for all 
GUIs to share) you must then install it as an engine in SCIDvsPC. Go to Tools > Analysis 
engines: 



 

Use the New button to add an engine. Give it a name, select the engine file and make sure it 
is set to use UCI as the protocol: 

 

Click Ok when done. 

9.2 Playing an engine 

Before starting a game go into the Analysis engines screen (Tools > Analysis engines), 
select the eBoard you want and click Start. The driver will load and connect to your board. 

Now you can start a normal game using Play > Computer UCI engine or Play > Internet 
(FICS). To play black use the Flip board button. Moves made on the eBoard will 
automatically be made on the screen so that the engine can reply. 

You can take back moves during a game. Wait until it is your turn to move then take back 
the computer's move and your own. When you have finished taking back moves click on the 
Resume button to continue playing. 

You can also enter a game or record the moves of a human vs human game by using Game 
> New game and entering the moves on the eBoard. 



10.  Legal stuff 

This software is distributed in the hope that it will be useful, but WITHOUT ANY 
WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A 
PARTICULAR PURPOSE. 

Copyright (C) 2020-2024 Graham O'Neill  [https://goneill.co.nz/chess] 

Piece graphics: By Wikipedia user Cburnett, via Wikimedia Commons  
   [CC BY-SA 3.0 (http://creativecommons.org/licenses/by-sa/3.0)] 

 


