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1.  Installation 

You must have a Chess Link module to attach your Millennium board to the computer. 
Without that my driver (or any other program on your computer) cannot talk to the board. 

1.1 Windows 

For Fritz and ChessBase the driver is 64 bit, which means it will only run in Fritz version 15 
and above, and ChessBase 13 and above. 

Download and run the setupMCL.exe program and it will lead you through installing the files 
(MCL_DLL.dll and gon-MCL64.dll) for the required programs. The setup program doesn't 
install for LucasChess as the drivers are already included in that program's download. 

For Arena, ChessBase, Fritz and Shredder the setup program will also install programs to 
allow you to select which board to use if you have multiple boards. For example, for Arena 
this is called "Arena eBoard" and will show you the screen: 

 

Which boards are listed depends on which drivers you have installed. The top of the screen 
shows which driver is currently selected (Millennium Chess Link in the above picture). In the 
list you can choose a different driver and then click Load to select it as the current driver. 
The option to Clear Current Driver allows you to revert to the DGT Rabbit Plugin if you have 
that installed for your DGT board. You do not need to install Rabbit for my drivers. 

1.2 Linux 

My program uses Pascal and Qt5 which might not work on your PC initially. If you find that 
the driver doesn't load at all install the Pascal/Qt5 support library by running: 

 Ubuntu/Debian: sudo apt install libqt5pas1 

 Fedora/Mageia: sudo dnf install qt5pas 
 
The only GUI that currently uses my driver is LucasChess and that already has it installed. If 
you want to reload it then you will need the libmcl.so file. You do not need the MCL_DLL.dll 
file. 



GUI File name Probable Location 

LucasChess libmcl.so /home/yourname/LucasChessR2/bin/OS/linux/DigitalBoards 

 
You will probably also have to grant your user name access to the serial ports using either 
chmod to grant RW access or by editing the \etc group file with sudo gedit group. 

 

2.  General information 

The Millennium will show you a COM port for the board which might be the port created 
using the USB cable link or might be the one created by the Bluetooth adapter in Chess 
Link. See below for notes relating to using the board with Bluetooth. 

Sometimes the system won't release the COM port even though my driver has finished and 
this will stop you from reconnecting the board again. In this case the easiest solution is to 
unplug the board's USB connection at the computer and plug it back in again. 

My driver screen cannot be closed using the normal close window button as that would leave 
the GUI without the response it is expecting. Normally it will close automatically when you 
complete the required action but if you need to force it to close (perhaps the driver keeps 
failing to talk to the board) then you need to do this by deactivating the board in the GUI. 

Note that for the eOne to connect using USB you must turn off Bluetooth on the board using 
the third button: 

 

The eOne doesn't seem to work with all USB cables so start by making sure it works with the 
cable supplied with the board before changing it to a different (longer) one. 

2.1 Using USB - Windows 

Most Millennium boards use the FTDI chip so you need to install the Windows FTDI driver, 
which can be downloaded from the HIARCS web page or directly from FTDI: 
 https://www.hiarcs.com/eboards/chesslink-drivers.html 
 https://ftdichip.com/drivers/vcp-drivers/ 

For the eOne board there is a different driver that can be downloaded from the Millennium 
web page or directly from WCH: 
 https://computerchess.com/en/downloads-2/#M841 
 http://www.wch-ic.com/downloads/CH341SER_ZIP.html 
 

2.2 Using USB - Linux 

Linux normally includes the FTDI drivers by default but you might need to allow access to 
the ttyUSB0 port by adding your user to the dialout group. The eOne uses a different driver, 
the QinHeng Electronics CH340. Again, drivers for this are normally installed by default. 
Having just plugged in the board run: 

 dmesg --human|tail 
  
If you see that the ttyUSB0 port has been taken over by brltty then you need to remove it: 

 sudo apt remove brltty -y 
 
You should then be able to access the board by setting up the appropriate udev rules. 



2.3 Using Bluetooth - Windows 

There are two types of Bluetooth connection available in Windows. For 'classic' Bluetooth 
you must first use the Microsoft Bluetooth pairing screen (Settings > Devices > Bluetooth) to 
connect to the board. The device you want is the Millennium Chess with the Audio 
Headphones symbol: 

 

You don't want the other Millennium chess device (with a PC symbol). You should then be 
able to see a COM port for the board that can be used by my driver. If not, you can check or 
create the port using Settings > Devices > Bluetooth > "More Bluetooth options" > COM 
Ports tab. You need a COM port labelled "Outgoing". 

You can also use BluetoothLE provided you have Windows 10 build 10.0.15063.0 (also 
known as version 1703) or later. This is from 2017 so any update since then will be OK. 
BluetoothLE might be slightly slower but uses less power so will be better if you run your 
board using a battery. 

You might also need to install the Microsoft Visual C++ Redistributable; the x86 version for 
Arena/LucasChess/Shredder and the x64 version for Fritz/ChessBase. You can download 
these from Microsoft's website (under "Other Tools, Frameworks, and Redistributables"): 
 
 https://visualstudio.microsoft.com/downloads/ 
 

 

Try my driver first without it as you might already have it installed. Once all of these 
conditions are met you can use the BluetoothLE option by selecting it in the Connection type 
on the Configuration screen of my driver. 

  



2.4 Using Bluetooth - Linux 

Use the Bluetooth Manager program to pair your board with the computer. Then in the right-
click menu make sure you have connected to a serial port: 

 

You can then use the board by using the Serial Port shown (rfcomm0 in the above screen). 

2.5 Configuration screen 

The first time you access my DLL file you will be prompted to set some configuration details 
to tell my driver how to connect to and use the board. 

Connection 
The COM port that your board is connected to. You can find this in the Ports section of 
Device Manager in Windows (C:\Windows\System32\devmgmt.msc), or you can select 
Auto to have my program find it for you. However the Auto option is slower as it tries to 
send and receive data from each port so it is better to be specific if you can. 

Debounce 
The Millennium sends a new position when it detects that a piece has been moved. But if 
you slide a piece then sometimes the board thinks it has a new position before the piece 
has finished moving. By setting the debounce value to something other than zero it will 
allow a short delay to ensure that the move is complete. The larger you make the value 
the longer and safer the wait, but also the slower the board will respond. Each unit means 
a wait of 25ms and the value can be between 0 (no wait) and 250 (6.25 seconds). A value 
of 2 or 3 seems to be adequate. 

LED mode 
This specifies when the LEDs on the board will be displayed. Normally they show for your 
moves and the computers, but the response will be slightly faster if you only show the 
LEDs when the computer moves. You can also turn off the LEDs completely, for example 
if you are using the board for a human vs. human game and just want the GUI to record 
the moves. 

Show possible moves 
This option is useful for people learning chess. When you pick up a piece the board will 
show you all the squares that the piece can be moved to. 



LED flash (Moves, Captures) 
The default is to have the LEDs on constantly when displaying the computer's move and 
flashing to highlight captures. You can change this so that the LEDs will flash when 
moves are displayed if that's what you prefer. 

LED flash speed 
You can adjust the speed at which the LEDs flash. My driver has different flash patterns 
for different situations, but the fastest flashing occurs when you attempt an illegal move. 
The value can be between 1 (very slow) and 255 (very fast), with 160 seeming to be a 
reasonable speed. The LED brightness can also be controlled, with values ranging 
between 0 (quite dim) and 15 (maximum brightness). 

LED brightness 
You can adjust the brightness of the LEDs using this option. A value of 0 is quite dim and 
the maximum value of 15 is full brightness. 

Board is rotated  (not eOne) 
The Millennium board can be setup with the cable on the right or left. It doesn't matter to 
my driver unless you try using the board to set up new positions. The easiest way to find 
out if you need to set this indicator is to start a new game but with one piece in the wrong 
position (e.g. a pawn on e4). You want to see the diagram on the left. If you see the one 
on the right then you should change the indicator. Note that for the BluetoothLE 
connection you might need to move a piece for it to update the current position. 

 

Board sensitivity  (eOne) 
For the eOne board you can set the board's sensitivity. The maximum value is 50 but if 
it's too sensitive then you might find it detects pieces that aren't there. At the lowest 
sensitivity value of 1 it might not detect pieces at all. A value of 35 is the default. 

The configuration data will be stored in a file called MCL_DLL.INI which will be in the same 
folder as the DLL file, unless that is in the "Program Files" directory in which case it will be 
your C:\Users folder. You can edit this file manually but must use a text editor like Notepad 
rather than a word processor like Word. There is an extra option in the file: 

BLEnoSearch=false 
This option, if set to "true", will force the driver to only connect to the last used board. This 
is useful if you have a room with multiple computers each with their own board. You first 
match each computer to its board by performing a full search when only those two 
devices are turned on. You then change all of the INI files to have "true" on this option. 



Now if a computer loses its connection it won't run a full scan and mistakenly link to a 
board that is allocated to a different computer. 

2.6 Setting up starting positions (not eOne) 

You can set up a starting position using the board. See the notes below for any special steps 
required for each GUI, but in general the following is the procedure to use. 

On the board remove both kings to put my driver into Setup mode. If there aren't any pieces 
on the board, put one on and take it off again. Now put the pieces where you want them on 
the board. The last piece you put on the board should be the king of the colour to move next. 

It is important that you make sure the driver knows which way the pieces move: is white or 
black playing from nearest you? The indicators above and below the board show which way 
around it is currently set to. For example, in this screen the white king is about to be placed 
on g1 (as it is white's move next) but you can see that the indicators are wrong as they show 
the black pieces should be nearest you: 

 

One way to correct this is to use the Rotate Board button on the screen. But you can also do 
it using the board by placing one king on an adjacent square to the other king. In this case, if 
you placed the white king on f6, g6 or h6 the driver will see that the white king is closest to 
you and will swap the indicators. You could swap them back (to being wrong) by placing the 
white king on f8 (after temporarily moving the black rook), g8 or h8 since then the black king 
would be closest. Since having the kings adjacent is illegal the driver won't leave Setup 
mode until you then move the white king to its correct g1 square. 

2.7 Flip the board and different starting positions (eOne) 

If you want to play with the board flipped (i.e. with the black pieces nearest you) on boards 
with piece recognition such as the Exclusive and Supreme you can just set up the pieces 
how you want them. 

For the eOne the process is slightly different. When you see the New Game or New Position 
screen make sure the white/back LED is set how you want it by pressing the left button: 

 

The LED should be lit if you want black nearest you. Then set up the position required and 
after that you should be able to continue as normal after pressing OK on the screen. 
Because the rotation is controlled this way, the "Board is rotated" option on the Configuration 
screen does not apply to the eOne. 



Note that BluetoothLE saves power by only sending the board position when a piece is 
moved, so sometimes you might need to lift and replace a piece for it to accept a starting 
position. 

In GUIs that allow you to set up or change positions during a game, you can access the 
screen to do this by lifting up both kings. For this to work on the eOne you must lift up the 
king of the side that can't move first, otherwise the eOne will think you want to make a 
move with your own king. Also you should make the first move before lifting the kings if you 
are in the starting position. You will see something like: 
 

 
 
Place the pieces on the board where you want them and then check that the screen is 
showing them correctly. Because the board doesn't have piece recognition you will see a red 
square and dot where an unidentified piece is located. You can correct this by clicking on the 
pieces to the side of the board and then clicking on the board. If you right-click then the 
piece of the opposite colour will be set. 
 
You must also use the rotation button on the screen, not the one on the eOne board 
described above to set the board orientation. Normally white is at the bottom. Also use the 
swap button to indicate which side has the next move. Press OK when everything is ready. 

2.8 Under promoting pawns (eOne) 

When a pawn is going to be promoted you need to be a bit more careful with the eOne board 
compared to boards with piece recognition. If the pawn is capturing a piece then lift that first. 
Then lift the pawn that is to be promoted. At this point the three LEDs shown above will 
flash. (If the engine is promoting then the board will also flash to show you which piece is 
required). If you want to promote to a queen just put the piece on the board, but if the move 
is an under promotion you must press one of the three buttons on the board before placing 
the piece. 

 

3.  Use with Arena 

3.1 Playing an engine 

In Engines > Manage select the engine you want to play against and in Levels set the time 
control to be used. Select File > New to start a new game. 



Connect the board to your computer, set up the pieces and activate the board using Extras > 
DGT - Chessboard: 

 

The first time you do this you must go to the Options tab of the screen that appears and set 
the details as shown here: 

 

Set up the configuration details in my driver if required. 

You can now make the first move as white, or click Game > Move Now! to make the 
computer play the first move. After that make moves on the board and they will appear on 
the Arena screen. 

If you want to play a new game use File > New again. 

3.2 Different starting positions 

You can start a game (or analysis) from a specific position but you must do it by setting the 
position up using the board. 

Select the engine(s) you want to use and activate the board as normal. You can click 'Skip' 
on my driver's New Game screen as you are going to set up a new position anyway. 
Select Position > Set-up a Position. 

On the board remove both kings to put my driver into Setup mode and follow the instructions 
given in General Information above. 

In the Arena Setup screen make sure the side to move and other indicators are correct and 
click OK. You can now make the first move or make the computer move or start the analysis 
as normal. 

3.3 Take back moves 

If you want to take back a move wait until it is your turn to play and then take back the 
moves you want on the board. The screen in Arena will automatically be updated. When you 
then make your amended move Arena will ask if this is a new variation or if the old moves 
should be overwritten. 

3.4 Analysing a game 

You can either use the Position > Set-up a Position option above to setup the pieces or you 
can make many moves manually and use this to either get to the starting position you want 
or analyse a game. You can also use this method to make Arena record the moves in a 
human vs. human game. 



Having selected the engine and started a new game click on Position > Analyze Now! (or 
click the Analyze button in the Moves window). This will start the engine analyzing the 
position (unless an opening book is selected, in which case nothing will happen until you are 
out of book) and you can makes moves on the board for both white and black. 

If you now want to play the engine from the current position turn off analyze mode. You can 
now make the next move or click Game > Move Now! to make the engine move. 

3.5 Replaying a game 

You can play through the moves of a saved game but unfortunately Arena doesn't send the 
move information to the board, so you need to follow the moves on the screen too. But you 
can still add and analyse variations. Get the board ready for a new game, load the PGN file 
you want and put Arena into Analysis mode. You can now go through the moves using the 
right-arrow key while making the moves on the board. 

 

4.  Use with CB-Emu (Arena) 

CB-Emu is a program by Franz Huber that allows you to play against old chess computers 
on your PC, using ROM emulations of their processors. 

The Setup installation for my driver will load the files into the appropriate folder (<path>\CB-
Emu\MessChess\Arena) and you can then use your eBoard by running the Arena.exe 
program from that folder. 

You can also run Arena directly from the MessChess.exe program but to do this you need to 
edit a file in the CB-Emu\MessChess folder. MessChess defaults to using Winboard rather 
than Arena, so change this by editing GUI.INI using a text editor (like Notepad), not a word 
processor (like Word). Change the first line from 1 to 2: 

 

 

5.  Use with Fritz and ChessBase 

5.1 Playing an engine 

Having set up the game details (engine, time etc) you can activate the board from the Board 
tab. For example, in the Easy Game menu: 

 

For PlayChess the option to enable the DGT board is on the Server Settings screen. 

The driver will then load and attempt to connect to the board. Once connected you can make 
the first move or make the engine move using the Move Now button. 



5.2 Different starting positions 

The Fritz and ChessBase programs are written expecting the board to be a DGT, which 
means they expect the board to have piece recognition. You can set up the position using 
the board: remove both kings to put my driver into Setup mode and follow the instructions 
given in General Information above. 

You can also start the board during a game or after using Home > Setup Position. When the 
board connects you will see the New Game screen. Set the board up with the pieces in the 
position of the game and then press the Read button. The driver will now load the position 
from the board into the screen. If the screen matches the position in Fritz check which side is 
shown as moving next and click OK to continue the game. 

5.3 Take back moves 

You can take back moves by waiting until it is you turn to move and then taking back the 
computer's last move and then your own move. The LEDs on the board will lead you through 
the sequence of moves. When you want to enter your replacement move just make it on the 
board. Fritz automatically adds this move as a new variation so you will need to right click on 
the variation and select Promote variation to make it the main line. 

5.4 Analysing a game 

To analyse a game or position put Fritz into Infinite Analysis mode and then either setup the 
position as above or make a sequence of moves from the starting position. You can also use 
this method to make Fritz record the moves in a human vs. human game. 

If you now want to play the engine from the current position turn off analyze mode. You can 
now make the next move or click Move Now to make the engine move. 

5.5 Replaying games 

You can also play through the moves of a saved game. Start a new game, connect the 
board and get it ready for white's first move. Put the engine into Analysis mode (or switch it 
off completely) and then load the game (for example using File > Open > Open Database). 
You will see the moves in the game panel. You can now play through the game using the 
right-arrow key, with the board's LEDs showing the moves. You can also arrow through a set 
of moves and then make them all on the board. 

It is possible to enter variations using the board but I have found this to be very unreliable. It 
seems to be safer to enter variation moves using the mouse on the screen while also playing 
the moves on the board. To return to the main line click on the move before your variation 
and my driver will prompt you to replace the pieces (this step doesn't appear to work at all 
using the original DGT Rabbit plugin so it looks like ChessBase never programmed this into 
their software). You can then continue playing through the game or enter another variation. 

You can jump to a future point in the game but then you won't be able to use the board to 
take moves back before that point. 

 

6.  Use with LucasChess 

In order to use my driver in LucasChess you need to tell the GUI that you have an electronic 
board. This is done through the Options > Configuration screen. Go to the Boards tab and 
select Millennium for Digital board. (In the old LucasChess turn on Enable DGT board). 

When using my board I prefer not to have the tutor popup on the screen so in the Engines 
Configuration I normally go to the Tutor tab and turn on Disabled at the beginning of the 
game. 

 



6.1 Playing an engine 

Use the Play option to select an engine to play against. This will show you a screen where 
you can select the opponent, choose the colour to play, set the time controls, specify a 
starting position and so on. Once you have completed this click the Accept button. 

If you didn't activate the board using the option on the Play screen you can now enable it 
using the button on the menu bar: 

 

Set up the configuration details in my driver if required, and then play the moves on the 
board and they will appear on the screen in LucasChess. 

To start a new game use the Cancel button and then Play again, or use Adjourn to save a 
game for continuation later. 

During a game you can change the current position by lifting up both kings, as described in 
the General Information section above. 

You can deactivate and activate the board again at any time. 

6.2 Different starting positions 

There are two places where you can set up special positions. One is when using Play 
against an engine (on the Initial moves tab) and the other is in Tools > Create your own 
game > Utilities > Change starting position > Edit starting position. Both will display a screen 
asking for the new position. 

You can also activate the board and then remove both kings to put my driver into Setup 
mode. Follow the instructions given in General Information above. Before replacing the kings 
you should make sure that the castling and en passant indicators are set how you want. 

6.3 Take back moves 

You can take back moves by waiting until it is you turn to move and then taking back the 
computer's last move and then your own move. The LEDs on the board will lead you through 
the sequence of moves. When you want to enter your replacement move just make it on the 
board. 

6.4 Analysing a game 

You can play through your own game by using the Tools > Create your own game option. 
Enter the moves you want, including taking back moves. To analyse a move double click on 
it in the move list panel. You can also use this method to make LucasChess record the 
moves in a human vs. human game. 

To enter a variation right-click on the move and use the Append variation button to display 
the variation screen. For this screen you cannot use the board though and must enter the 
moves using the mouse. 

 

 



6.5 Replaying games 

You can also play through the moves of a saved game. Start a new game and get the board 
ready for white's first move. Load the game using Tools > PGN > Load PGN file and you will 
see the moves in the game panel. Move to the beginning of the game and enable the board. 
You can now play through the game using the right-arrow key, with the board's LEDs 
showing the moves. You can also arrow through a set of moves and then make them all on 
the board. 

If you want to enter a variation just make a different move from the one in the file and play 
through the moves you want. To return to the main line click on the move before your 
variation and my driver will prompt you to replace the pieces. You can then continue playing 
through the game. 

You can jump to a future point in the game but then you won't be able to use the board to 
take moves back before that point. 

6.6 Training with a book 

The option Train > Opening > Training with a book allows you to practise your opening 
repertoire. Load the opening book (a polyglot file with .bin extension) and enable the board. 
You can then make the moves from the book, and if you get a move wrong then the board 
will highlight your error. Use the Reinit button to start again from the beginning. 

 

7.  Use with Shredder 

7.1 Playing an engine 

When you select File > New Game you can select the strength of the opponent or you can 
use Levels to set the strength and time controls. 

To activate the board use Mode > External Board > DGT Board: 

 

Set up the configuration details in my driver if required, and then play the first move as white. 
If you want to play black select Commands > Compute / Switch Sides and the computer will 
make its move. 

To start a new game either select File > New Game or return all the pieces to the starting 
position on the board. 

As with the other GUIs it is a good idea to deactivate the board before quitting the GUI. 

 



7.2 Different starting positions 

There are two ways to set up a position to start playing from. Shredder only sends and 
receives piece positions not more detailed game information, so if your position includes 
restricted castling rights even though the king and rooks are in the correct positions then you 
should use the Edit Position method. 

Edit position 
You can use File > Edit Position (or the Edit Position button) to set up a new starting 
position. Make sure the board is activated first as the new position is sent to the board 
when you click OK. You should see the 'New Position' screen in my driver. Then you must 
also check that the correct side to move is indicated on my screen. If not use the button 
on the screen to change it: 

 

 
Using the board 

On the board remove both kings to put my driver into Setup mode and follow the 
instructions given in General Information above. 

7.3 Take back moves 

If you want to take back a move wait until it is your turn to play and then take back the 
moves you want on the board. The screen in Shredder will automatically be updated. When 
you then make your amended move Shredder will ask if this is a new variation or if the old 
moves should be overwritten. 

Note that with my driver when you take back a move the Shredder clock is also rewound to 
the correct time. This doesn't happen if you play with Shredder on your screen and use the 
Take Back button. 

7.4 Analysing a game 

You can use the Mode > Analysis option to allow you to make multiple moves on the board 
with the engine analysing the positions. You can also make take back moves and create 
new variations, or if you want to continue playing against the engine from the current position 
use Mode > Play against Computer. 

7.5 Replaying a game 

You can play through the moves of a saved game but unfortunately Shredder doesn't send 
the move information to the board, so you need to follow the moves on the screen too. But 
you can still add and analyse variations. Get the board ready for a new game, load the PGN 
file you want using File > Load Game and put Shredder into Analysis mode. You can now go 
through the moves using the right-arrow key while making the moves on the board. 

To enter a variation just make a different move to the one in the game. Unfortunately, to 
return to the main line you need to manually take back the moves in the variation before you 
can then continue the game. 

 

 

 



8.  Use as a UCI or Winboard engine 

For GUIs that don't support the DLL version of my driver I have also created an engine 
version. This can be used in an engine vs engine game to allow you to use your board for 
playing games. Some of the disadvantages of playing like this are: 

Ÿ You are not allowed to take back moves in engine matches 

Ÿ You can't play "rated" games 

Ÿ Opening book options might be limited 

Ÿ Time control options are often limited (it isn't always possible to give one engine more 
time than the other) 

The engine supports both the Winboard and UCI protocols. 

My DLL driver and Winboard engine both use an INI file to store the settings, which gave me 
a choice for the UCI engine. I decided to keep it the same as the other two, so the 
configuration of the driver in UCI mode is controlled by the Config tab of my screen rather 
than the UCI engine configuration in the GUI. 

8.1 Installation 

My Setup program will ask you where to install the engine file. I recommend that you create 
a main folder for holding any of my eBoard engines that you want to load and that when you 
"install" them into each GUI that you link to them from that folder. If you load them separately 
into each GUI you will need to manually copy the files again each time I issue an update. It 
also means that the eBoard will use the same INI file settings across all of the GUIs you use. 

The process of installing the engine into the GUI depends on each GUI, but in general you 
will need to give the engine a name and identify where the EXE file is. 

8.2 Playing an engine 

How you create an engine vs engine match also depends on how the GUI works. You might 
find that some GUIs also start the engine during the match setup in which case my driver 
screen will appear quite early. 

Also, some GUIs don't close the engine when an engine match is finished so you might need 
to either start a different match or use the "Close engine" option in the GUI to close my driver 
screen. 

 

9.  Use with SCIDvsPC 

Although SCIDvsPC uses the UCI engine version of my driver it has been amended to allow 
for take back moves and so on. It is used by adding it as a secondary Analysis engine rather 
than the main engine in a computer vs computer match. 

9.1 Installation 

Having installed the driver file using the Setup program (probably to a common folder for all 
GUIs to share) you must then install it as an engine in SCIDvsPC. Go to Tools > Analysis 
engines: 



 

Use the New button to add an engine. Give it a name, select the engine file and make sure it 
is set to use UCI as the protocol: 

 

Click Ok when done. 

9.2 Playing an engine 

Before starting a game go into the Analysis engines screen (Tools > Analysis engines), 
select the eBoard you want and click Start. The driver will load and connect to your board. 

Now you can start a normal game using Play > Computer UCI engine or Play > Internet 
(FICS). To play black use the Flip board button. Moves made on the eBoard will 
automatically be made on the screen so that the engine can reply. 

You can take back moves during a game. Wait until it is your turn to move then take back 
the computer's move and your own. When you have finished taking back moves click on the 
Resume button to continue playing. 

You can also enter a game or record the moves of a human vs human game by using Game 
> New game and entering the moves on the eBoard. 

 

 



10.  Legal stuff 

This software is distributed in the hope that it will be useful, but WITHOUT ANY 
WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A 
PARTICULAR PURPOSE. 
 

Copyright (C) 2020-2024 Graham O'Neill  [https://goneill.co.nz/chess] 
 

Piece graphics: By Wikipedia user Cburnett, via Wikimedia Commons  
   [CC BY-SA 3.0 (http://creativecommons.org/licenses/by-sa/3.0)] 


