DGT chess board driver
by Graham O'Neill

1. Installation

1.1 Windows

For Fritz and ChessBase the driver is 64 bit, which means it will only run in Fritz version 15
and above, and ChessBase 13 and above.

Download and run the setupDGT.exe program and it will lead you through installing the files
(DGT_DLL.dIl and gon-DGT64.dll) for the required programs. The setup program doesn't
install for LucasChess as the drivers are already included in that program's download.

For Arena, ChessBase, Fritz and Shredder the setup program will also install programs to
allow you to select which board to use if you have multiple boards. For example, for Arena
this is called "Arena eBoard" and will show you the screen:
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Board 1] File Version Date
Certabo CER_DLL 3.3 10 Sep 2022 1014
Chessnut &ir NUT_DLL 1.3 10 Sep 2022 1014
DGT DGT_DLL 2.2 10 Sep 2022 1015
DGT Pegasus PEG_DLL 2.5 10 Sep 2022 10115
Movag Citrine CIT DLL 3.2 10 Sep 2022 10014
Movag UCE UCE_DLL 4.2 10 Sep 2022 1016
Square Off Pro SOP_DLL 1.4 10 Sep 2022 115

Load Clear Current Exit
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Which boards are listed depends on which drivers you have installed. The top of the screen
shows which driver is currently selected (Millennium Chess Link in the above picture). In the
list you can choose a different driver and then click Load to select it as the current driver.
The option to Clear Current Driver allows you to revert to the DGT Rabbit Plugin if you have
that installed for your DGT board. You do not need to install Rabbit for my drivers.

1.2 Linux

My program uses Pascal and Qt5 which might not work on your PC initially. If you find that
the driver doesn't load at all install the Pascal/Qt5 support library by running:

Ubuntu/Debian: sudo apt install libgt5pasl
Fedora/Mageia: sudo dnf install gt5pas

The only GUI that currently uses my driver is LucasChess and that already has it installed. If
you want to reload it then you will need the libdgt.so file. You do not need the DGT_DLL.dII
file.

GUI File name Probable Location

LucasChess libdgt.so /home/yourname/LucasChessR2/bin/OS/linux/DigitalBoards




You will probably also have to grant your user name access to the serial ports using either
chmod to grant RW access or by editing the \etc group file with sudo gedit group.

2. General information

Sometimes the system won't release the COM port even though my driver has finished and
this will stop you from reconnecting the board again. In this case the easiest solution is to
unplug the board's USB connection at the computer and plug it back in again.

My driver screen cannot be closed using the normal close window button as that would leave
the GUI without the response it is expecting. If you need to force it to close (perhaps the
driver keeps failing to talk to the board) then you need to do this by deactivating the board in
the GUI.

2.1 Using Bluetooth to connect

If you have the Bluetooth DGT board then you will need to setup the connection first.

Since this board uses "classic" Bluetooth rather than BluetoothLE it is necessary to pair the
board to your PC. You do this using the normal process of pairing a device, but for Windows
11 there is a trick to being able to discover the board. In the Windows Settings > Bluetooth &
devices > Devices screen scroll down to the Device Settings section and select "Advanced"
for the Discovery type:
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2.2 Using a DGT clock

My driver will control a DGT 3000 or DGT XL clock in Fritz, LucasChess and Shredder,
showing the players times (if a time control is used) as well as the moves. For Arena only the
moves are shown as Arena 3.5.1 doesn't seem to output time information.

The DGT clocks have a special mode that is intended for use when a program is controlling
them. My normal routine to start the program is:

1 Attach the clock to the board with its cable

1 Attach the board to the computer with the USB cable

1 Turn on the power to the clock

1 When the clock is first turned on it will show the "Option" item flashing. Use the + and
- buttons to select item 25 (I think for the XL clock this should be 23, so maybe some

models use 24 instead). You should see '-: ——.-- —:--.--"as the time. Then press
the right Play [>*] button (not the middle [>||] one) and the Option will stop flashing.

After this it should work properly.



2.3 Configuration screen

The first time you access my DLL file you will be prompted to set some configuration details
to tell my driver how to connect to and use the board. This screen also appears when you
start a new game or new position, but not during normal play. If you want to change the
configuration during a game you should deactivate and reactivate the board (but not in
Arena - see below!)

Connection
The COM port that your board is connected to. You can find this in the Ports section of
Device Manager in Windows (C:\Windows\System32\devmgmt.msc), or you can select
Auto to have my program find it for you. However the Auto option is slow as it tries to
send and receive data from each port so it is better to be specific if you can.

Debounce
The DGT sends a new position when it detects that a piece has been moved. But if you
slide a piece then sometimes the board thinks it has a new position before the piece has
finished moving. By setting the debounce value to something other than zero it will allow
a short delay to ensure that the move is complete. The larger you make the value the
longer and safer the wait, but also the slower the board will respond. The number entered
is the millisecond wait and the value can be between 0 (no wait) and 1000 (1 second). A
value of 125 seems to be adequate.

Show possible moves
This option is useful for people learning chess. When you pick up a piece the board will
show you all the squares that the piece can be moved to.

Colours for displaying the board
Because the DGT board has no LEDs my driver shows a screen displaying the board.
Moves and errors (where you move an invalid piece) are shown. Also when taking back
moves in the game the next take back move is shown to help guide you back, and if this
means pieces need to be replaced then those pieces are highlighted too. Each of these
can be displayed in a different colour on the board.

Clock beep
If you have a DGT clock then it can be made to beep when the computer makes a move.
For the DGT XL a value of 0 means no beep and anything else means beep. For the DGT
3000 this value specifies the length of the beep (in units of 64ms).

Use SAN
Moves are shown on the DGT 3000 if it is attached using either long algebraic notation,
such as "g8-f6", or short algebraic notation (SAN), like "Nf6". This is ignored for the DGT
XL which only uses LAN. My driver always shows SAN moves using capital letters for the
pieces, while Rabbit shows black pieces in lower case (like "nf6").

Rewind clock (Shredder moves)
On boards with LEDs it is relatively quick to move the pieces for computer moves. But for
the DGT you have to either read the move from the clock or see it on the computer
screen before moving the piece, which can be slower. Shredder allows an attached DGT
clock to control the players times so this option will allow my driver to detect the time
when the computer move was sent and when you finished moving the piece on the board.
It can then rewind the clock, meaning you lose no time at all in making the computer's
moves.

The configuration data will be stored in a file called DGT_DLL.INI which will be in the same
folder as the DLL file, unless that is in the "Program Files" directory in which case it will be
your C:\Users folder. You can edit this file manually but must use a text editor like Notepad
rather than a word processor like Word.



2.4 Setting up starting positions

You can set up a starting position using the board. See the notes below for any special steps
required for each GUI, but in general the following is the procedure to use.

On the board remove both kings to put my driver into Setup mode. If there aren't any pieces
on the board, put one on and take it off again. Now put the pieces where you want them on
the board. The last piece you put on the board should be the king of the colour to move next.

It is important that you make sure the driver knows which way the pieces move: is white or
black playing from nearest you? The indicators above and below the board show which way
around it is currently set to. For example, in this screen the white king is about to be placed
on g1 (as it is white's move next) but you can see that the indicators are wrong as they show
the black pieces should be nearest you:

One way to correct this is to use the Rotate Board button on the screen. But you can also do
it using the board by placing one king on an adjacent square to the other king. In this case, if
you placed the white king on 6, g6 or h6 the driver will see that the white king is closest to
you and will swap the indicators. You could swap them back (to being wrong) by placing the
white king on f8 (after temporarily moving the black rook), g8 or h8 since then the black king
would be closest. Since having the kings adjacent is illegal the driver won't leave Setup
mode until you then move the white king to its correct g1 square.

3. Use with Arena

My driver or Rabbit?
Since Arena never sends positions or times to the DGT, there is very little difference
between my driver and Rabbit. The only real differences are the display of SAN moves
and the highlighting of take back moves on the screen.

3.1 Playing an engine

In Engines > Manage select the engine you want to play against and in Levels set the time
control to be used. Select File > New to start a new game.

Connect the board to your computer, set up the pieces and activate the board using Extras >
DGT - Chessboard:

Book Options Help
_ B¥ DGT - Chessboard * Alt+F11 -

The first time you do this you must go to the Options tab of the screen that appears and set
the details as shown here:



si: DGT - Chessboard - O -

Start | Options | Communication

Clock
Use DGT Chess clock
DGET-XL clock RMNEQKP

Show Arena move on DGT-XL clock Pieces |RMBOQKP

[ Show evaluation on clock

Value:

Set up the configuration details in my driver if required.

You can now make the first move as white, or click Game > Move Now!to make the
computer play the first move. After that make moves on the board and they will appear on
the Arena screen.

If you want to play a new game use File > New again.

3.2 Different starting positions

You can start a game (or analysis) from a specific position but you must do it by setting the
position up using the board.

Select the engine(s) you want to use and activate the board as normal. You can click 'Skip'
on my driver's New Game screen as you are going to set up a new position anyway.
Select Position > Set-up a Position.

On the board remove both kings to put my driver into Setup mode and follow the instructions
given in General Information above.

In the Arena Setup screen make sure the side to move and other indicators are correct and
click OK. You can now make the first move or make the computer move or start the analysis
as normal.

3.3 Take back moves

If you want to take back a move wait until it is your turn to play and then take back the
moves you want on the board. The screen in Arena will automatically be updated. When you
then make your amended move Arena will ask if this is a new variation or if the old moves
should be overwritten.

3.4 Analysing a game

You can either use the Position > Set-up a Position option above to setup the pieces or you
can make many moves manually and use this to either get to the starting position you want
or analyse a game. You can also use this method to make Arena record the moves in a
human vs. human game.

Having selected the engine and started a new game click on Position > Analyze Now! (or
click the Analyze button in the Moves window). This will start the engine analyzing the
position (unless an opening book is selected, in which case nothing will happen until you are
out of book) and you can makes moves on the board for both white and black.

If you now want to play the engine from the current position turn off analyze mode. You can
now make the next move or click Game > Move Now!to make the engine move.



3.5 Replaying a game

You can play through the moves of a saved game but unfortunately Arena doesn't send the
move information to the board, so you need to follow the moves on the screen too. But you
can still add and analyse variations. Get the board ready for a new game, load the PGN file
you want and put Arena into Analysis mode. You can now go through the moves using the

right-arrow key while making the moves on the board.

4. Use with CB-Emu (Arena)

CB-Emu is a program by Franz Huber that allows you to play against old chess computers
on your PC, using ROM emulations of their processors.

The Setup installation for my driver will load the files into the appropriate folder (<path>\CB-
Emu\MessChess\Arena) and you can then use your eBoard by running the Arena.exe
program from that folder.

You can also run Arena directly from the MessChess.exe program but to do this you need to
edit a file in the CB-Emu\MessChess folder. MessChess defaults to using Winboard rather
than Arena, so change this by editing GUL.INI using a text editor (like Notepad), not a word
processor (like Word). Change the first line from 1 to 2:

| GULini - Notepad

File Edit Format View Help
2

First line: GUI for MessChess

WinBoard (default)
Arena

fod =
non

5. Use with Fritz and ChessBase

5.1 Playing an engine

Having set up the game details (engine, time etc) you can activate the board from the Board
tab. For example, in the Easy Game menu:

File Home Board Openings View Help
% Board Sounds - % t DGT Board -@
vl Coordinates ' .‘ i
Flip ] Always Promate To Quesn Square Pleces Table 3D Raytraced GPU accelerated
Board > Board~ board = raytracing [DX12)~
Board Board 2d Board 3d DGT board

For PlayChess the option to enable the DGT board is on the Server Settings screen.

The driver will then load and attempt to connect to the board. Once connected you can make
the first move or make the engine move using the Move Now button.

5.2 Different starting positions

The Fritz and ChessBase programs are written expecting the board to be a DGT, which
means they expect the board to have piece recognition. You can set up the position using
the board: remove both kings to put my driver into Setup mode and follow the instructions
given in General Information above.



You can also start the board during a game or after using Home > Setup Position. When the
board connects you will see the New Game screen. Set the board up with the pieces in the
position of the game and then press the Read button. The driver will now load the position
from the board into the screen. If the screen matches the position in Fritz check which side is
shown as moving next and click OK to continue the game.

5.3 Take back moves

You can take back moves by waiting until it is you turn to move and then taking back the
computer's last move and then your own move. The display of the board will lead you
through the sequence of moves. When you want to enter your replacement move just make
it on the board. Fritz automatically adds this move as a new variation so you will need to
right click on the variation and select Promote variation to make it the main line.

5.4 Analysing a game

To analyse a game or position put Fritz into Infinite Analysis mode and then either setup the
position as above or make a sequence of moves from the starting position. You can also use
this method to make Fritz record the moves in a human vs. human game.

If you now want to play the engine from the current position turn off analyze mode. You can
now make the next move or click Move Now to make the engine move.

5.5 Replaying games

You can also play through the moves of a saved game. Start a new game, connect the
board and get it ready for white's first move. Put the engine into Analysis mode (or switch it
off completely) and then load the game (for example using File > Open > Open Database).
You will see the moves in the game panel. You can now play through the game using the
right-arrow key, with the board's LEDs showing the moves. You can also arrow through a set
of moves and then make them all on the board.

It is possible to enter variations using the board but | have found this to be very unreliable. It
seems to be safer to enter variation moves using the mouse on the screen while also playing
the moves on the board. To return to the main line click on the move before your variation
and my driver will prompt you to replace the pieces (this step doesn't appear to work at all
using the original DGT Rabbit plugin so it looks like ChessBase never programmed this into
their software). You can then continue playing through the game or enter another variation.

You can jump to a future point in the game but then you won't be able to use the board to
take moves back before that point.

6. Use with LucasChess

In order to use my driver in LucasChess you need to tell the GUI that you have an electronic
board. This is done through the Options > Configuration screen. Go to the Boards tab and
select DGT Alternate (Windows) or DGT (Linux) for Digital board. DGT on Windows will use
the Rabbit driver instead. (In the old LucasChess turn on Enable DGT board).

When using my board | prefer not to have the tutor popup on the screen so in the Engines
Configuration | normally go to the Tutortab and turn on Disabled at the beginning of the
game.

My driver or Rabbit?
In addition to the format of SAN moves and the highlighting of take back moves on the
screen my driver has some other advantages. One is that my driver accepts FEN format
positions from the GUI so it will validate castling and en passant moves properly when
starting a game from a special position. It also sends information about take back moves
to the GUI so you don't need to click on the "Takeback" button.



6.1 Playing an engine

Use the Play option to select an engine to play against. This will show you a screen where
you can select the opponent, choose the colour to play, set the time controls, specify a
starting position and so on. You should also say that you want to activate the DGT board.
Once you have completed this click the Accept button.

If you didn't activate the board using the option on the Play screen you can now enable it

using the button on the menu bar:
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My driver is called DGT-gon inside LucasChess to distinguish it from the official DGT Rabbit
driver.

Set up the configuration details in my driver if required, and then play the moves on the
board and they will appear on the screen in LucasChess.

To start a new game use the Cancel button and then Play again, or use Adjourn to save a
game for continuation later.

You can deactivate and activate the board again at any time.

6.2 Different starting positions

There are two places where you can set up special positions. One is when using Play
against an engine (on the Initial moves tab) and the other is in Tools > Create your own
game > Utilities > Change starting position > Edit starting position. Both will display a screen
asking for the new position.

Activate the board and then remove both kings to put my driver into Setup mode. Follow the
instructions given in General Information above. Before replacing the kings you should make
sure that the castling and en passant indicators are set how you want.

6.3 Take back moves

You can take back moves by waiting until it is you turn to move and then taking back the
computer's last move and then your own move. The display of the board will lead you
through the sequence of moves. When you want to enter your replacement move just make
it on the board.

6.4 Analysing a game

You can play through your own game by using the Tools > Create your own game option.
Enter the moves you want, including taking back moves. To analyse a move double click on
it in the move list panel. You can also use this method to make LucasChess record the
moves in a human vs. human game.

To enter a variation right-click on the move and use the Append variation button to display
the variation screen. For this screen you cannot use the board though and must enter the
moves using the mouse.



6.5 Replaying games

You can also play through the moves of a saved game. Start a new game and get the board
ready for white's first move. Load the game using Tools > PGN > Load PGN file and you will
see the moves in the game panel. Move to the beginning of the game and enable the board.
You can now play through the game using the right-arrow key, with the display of the board
showing the moves. You can also arrow through a set of moves and then make them all on
the board.

If you want to enter a variation just make a different move from the one in the file and play
through the moves you want. To return to the main line click on the move before your
variation and my driver will prompt you to replace the pieces. You can then continue playing
through the game.

You can jump to a future point in the game but then you won't be able to use the board to
take moves back before that point.

6.6 Training with a book

The option Train > Opening > Training with a book allows you to practise your opening
repertoire. Load the opening book (a polyglot file with .bin extension) and enable the board.
You can then make the moves from the book, and if you get a move wrong then the screen
will highlight your error. Use the Reinit button to start again from the beginning.

7. Use with Shredder

Due to a bug in how Shredder sends the times to the DGT clock you might notice that time
increments aren't shown correctly on your clock for the first couple of moves. For the same
reason it isn't possible to rewind the clock for the time taken moving the computer's pieces
during those first moves.

My driver or Rabbit?
In addition to the format of SAN moves and the highlighting of take back moves on the
screen my driver has the advantage that it allows you to rewind the clock to the start of
your move when making a computer move on the board. This means you don't lose time
moving the computers pieces.

7.1 Playing an engine

When you select File > New Game you can select the strength of the opponent or you can
use Levels to set the strength and time controls.

To activate the board use Mode > External Board > DGT Board:
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Computer vs, Computer > | -
i External Board » DGT Board
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Set up the configuration details in my driver if required, and then play the first move as white.
If you want to play black select Commands > Compute / Switch Sides and the computer will
make its move.

To start a new game either select File > New Game or return all the pieces to the starting
position on the board.

As with the other GUIs it is a good idea to deactivate the board before quitting the GUI.

7.2 Different starting positions

There are two ways to set up a position to start playing from. Shredder only sends and
receives piece positions not more detailed game information, so if your position includes
restricted castling rights even though the king and rooks are in the correct positions then you
should use the Edit Position method.

Edit position
You can use File > Edit Position (or the Edit Position button) to set up a new starting
position. Make sure the board is activated first as the new position is sent to the board
when you click OK. You should see the 'New Position' screen in my driver. Then you must
also check that the correct side to move is indicated on my screen. If not use the button
on the screen to change it:

Using the board
On the board remove both kings to put my driver into Setup mode and follow the
instructions given in General Information above.

7.3 Take back moves

If you want to take back a move wait until it is your turn to play and then take back the
moves you want on the board. The screen in Shredder will automatically be updated. When
you then make your amended move Shredder will ask if this is a new variation or if the old
moves should be overwritten.

Note that with my driver when you take back a move the Shredder clock is also rewound to
the correct time. This doesn't happen if you play with Shredder on your screen and use the
Take Back button.

7.4 Analysing a game

You can use the Mode > Analysis option to allow you to make multiple moves on the board
with the engine analysing the positions. You can also make take back moves and create
new variations, or if you want to continue playing against the engine from the current position
use Mode > Play against Computer.

7.5 Replaying a game

You can play through the moves of a saved game but unfortunately Shredder doesn't send
the move information to the board, so you need to follow the moves on the screen too. But
you can still add and analyse variations. Get the board ready for a new game, load the PGN
file you want using File > Load Game and put Shredder into Analysis mode. You can now go
through the moves using the right-arrow key while making the moves on the board.



To enter a variation just make a different move to the one in the game. Unfortunately, to
return to the main line you need to manually take back the moves in the variation before you
can then continue the game.

8. Use as a UCI or Winboard engine

For GUIs that don't support the DLL version of my driver | have also created an engine
version. This can be used in an engine vs engine game to allow you to use your board for
playing games. Some of the disadvantages of playing like this are:

1 You are not allowed to take back moves in engine matches
1 Youcan't play "rated" games

1 Opening book options might be limited

i

Time control options are often limited (it isn't always possible to give one engine more
time than the other)

The engine supports both the Winboard and UCI protocols.

My DLL driver and Winboard engine both use an INI file to store the settings, which gave me
a choice for the UCI engine. | decided to keep it the same as the other two, so the
configuration of the driver in UCI mode is controlled by the Config tab of my screen rather
than the UCI engine configuration in the GUI.

8.1 Installation

My Setup program will ask you where to install the engine file. | recommend that you create
a main folder for holding any of my eBoard engines that you want to load and that when you
"install" them into each GUI that you link to them from that folder. If you load them separately
into each GUI you will need to manually copy the files again each time | issue an update. It
also means that the eBoard will use the same INI file settings across all of the GUIs you use.

The process of installing the engine into the GUI depends on each GUI, but in general you
will need to give the engine a name and identify where the EXE file is.

8.2 Playing an engine

How you create an engine vs engine match also depends on how the GUI works. You might
find that some GUIs also start the engine during the match setup in which case my driver
screen will appear quite early.

Also, some GUIs don't close the engine when an engine maitch is finished so you might need
to either start a different match or use the "Close engine" option in the GUI to close my driver
screen.

9. Use with SCIDvsPC

Although SCIDvsPC uses the UCI engine version of my driver it has been amended to allow
for take back moves and so on. It is used by adding it as a secondary Analysis engine rather
than the main engine in a computer vs computer match.

9.1 Installation

Having installed the driver file using the Setup program (probably to a common folder for all
GUIs to share) you must then install it as an engine in SCIDvsPC. Go to Tools > Analysis
engines:
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Use the New button to add an engine. Give it a name, select the engine file and make sure it
is set to use UCI as the protocol:

ﬁ Configure Engine — (=] -

Name eBoard MUT

Command |D:/eBoards/MUT_ENG exe Browse

Directory | ; scid_exe |:|ir|
Parameters

Webpage Open
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Fields in bold are required; others are optional

OK Help Cancel

Click Ok when done.

9.2 Playing an engine

Before starting a game go into the Analysis engines screen (Tools > Analysis engines),
select the eBoard you want and click Start. The driver will load and connect to your board.

Now you can start a normal game using Play > Computer UCI engine or Play > Internet
(FICS). To play black use the Flip board button. Moves made on the eBoard will
automatically be made on the screen so that the engine can reply.

You can take back moves during a game. Wait until it is your turn to move then take back

the computer's move and your own. When you have finished taking back moves click on the
Resume button to continue playing.

You can also enter a game or record the moves of a human vs human game by using Game
> New game and entering the moves on the eBoard.



10. Legal stuff

This software is distributed in the hope that it will be useful, but WITHOUT ANY
WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A

PARTICULAR PURPOSE.
Copyright (C) 2021-2024 Graham O'Neill [https://goneill.co.nz/chess]

Piece graphics: By Wikipedia user Cburnett, via Wikimedia Commons
[CC BY-SA 3.0 (http://creativecommons.org/licenses/by-sa/3.0)]



