Novag Citrine DLL driver

by Graham O'Neill

1. Installation

1.1 Windows

For Fritz and ChessBase the driver is 64 bit, which means it will only run in Fritz version 15
and above, and ChessBase 13 and above.

Download and run the setupCIT.exe program and it will lead you through installing the files
(CIT_DLL.dIl and gon-CIT64.dll) for the required programs. The setup program doesn't
install for LucasChess as the drivers are already included in that program's download.

For Arena, ChessBase, Fritz and Shredder the setup program will also install programs to
allow you to select which board to use if you have multiple boards. For example, for Arena
this is called "Arena eBoard" and will show you the screen:
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Board 1] File Version Date
Certabo CER_DLL 3.3 10 Sep 2022 1014
Chessnut &ir NUT_DLL 1.3 10 Sep 2022 1014
DGT DGT_DLL 2.2 10 Sep 2022 1015
DGT Pegasus PEG_DLL 2.5 10 Sep 2022 10115
Movag Citrine CIT DLL 3.2 10 Sep 2022 10014
Movag UCE UCE_DLL 4.2 10 Sep 2022 1016
Square Off Pro SOP_DLL 1.4 10 Sep 2022 115

Load Clear Current Exit
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Which boards are listed depends on which drivers you have installed. The top of the screen
shows which driver is currently selected (Millennium Chess Link in the above picture). In the
list you can choose a different driver and then click Load to select it as the current driver.
The option to Clear Current Driver allows you to revert to the DGT Rabbit Plugin if you have
that installed for your DGT board. You do not need to install Rabbit for my drivers.

1.2 Linux

My program uses Pascal and Qt5 which might not work on your PC initially. If you find that
the driver doesn't load at all install the Pascal/Qt5 support library by running:

Ubuntu/Debian: sudo apt install libgt5pasl
Fedora/Mageia: sudo dnf install gt5pas

The only GUI that currently uses my driver is LucasChess and that already has it installed. If
you want to reload it then you will need the libcit.so file. You do not need the CIT_DLL.dIl file:

GUI File name Probable Location

LucasChess libcit.so /home/yourname/LucasChessR2/bin/OS/linux/DigitalBoards




You will probably also have to grant your user name access to the serial ports using either
chmod to grant RW access or by editing the \etc group file with sudo gedit group.

2. General information

Sometimes the system won't release the COM port even though my driver has finished and
this will stop you from reconnecting the board again. In this case the easiest solution is to
unplug the board's USB connection at the computer and plug it back in again.

My driver screen cannot be closed using the normal close window button as that would leave
the GUI without the response it is expecting. Normally it will close automatically when you
complete the required action but if you need to force it to close (perhaps the driver keeps
failing to talk to the board) then you need to do this by deactivating the board in the GUI.

2.1 Configuration screen

The first time you access my DLL file you will be prompted to set some configuration details
to tell my driver how to connect to and use the board.

Connection
The COM port that your board is connected to. You can find this in the Ports section of
Device Manager in Windows (C:\Windows\System32\devmgmt.msc), or you can select
Auto to have my program find it for you. However the Auto option is slow as it tries to
send and receive data from each port so it is better to be specific if you can.

Flash moves
On the Citrine this program was tested on it was necessary to enable this option in order
to show the LEDs for moves on the board. However, using it also generates an error
message on the Citrine screen: "Error, verify square XX'. Unfortunately if your Citrine
needs Flash moves in order to display the LEDs properly then you will have to learn to
ignore the error message.

The configuration data will be stored in a file called CIT_DLL.INI which will be in the same

folder as the DLL file, unless that is in the "Program Files" directory in which case it will be

your C:\Users folder. You can edit this file manually but must use a text editor like Notepad
rather than a word processor like Word.

2.2 Special starting positions

In LucasChess and Shredder you can set up a special starting position for the game so that
you can solve puzzles or play on from that point in the game. When my driver prompts you
for the new position you must first place the pieces on their normal starting position and you
can then move them to their correct position.

3. Use with Arena

If you only use Arena for playing an engine or analysing games then you do not need my
driver as Arena has built in support for the Citrine. If you play online with one of the Internet
servers then my driver is better. The Arena interface to the Citrine has a bug where the
LEDs aren't shown for moves made by your opponent while my driver works properly for
that.

A problem with Arena is that it never sends actual positions to the driver, so it isn't possible
to start a game from a position other than the normal starting position.



3.1 Playing an engine

In Engines > Manage select the engine you want to play against and in Levels set the time
control to be used. Select File > New to start a new game.

Connect the board to your computer, set up the pieces and activate the board using Extras >
DGT - Chessboard. Note that since you are using my driver, which replaces the DGT driver,
you must activate the DGT board here not the built in Citrine driver:
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The first time you do this you must go to the Options tab of the screen that appears and set
the details as shown here:
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Set up the configuration details in my driver if required.

You can now make the first move as white, or click Game > Move Now!to make the
computer play the first move. After that make moves on the board and they will appear on
the Arena screen.

If you want to play a new game use File > New again.

3.2 Take back moves

If you want to take back a move wait until it is your turn to play and then take back the
moves you want on the board. The screen in Arena will automatically be updated. When you
then make your amended move Arena will ask if this is a new variation or if the old moves
should be overwritten.

3.3 Analysing a game

Although Arena won't allow you to start from a specific position you can make many moves
manually and use this to either get to the starting position you want or analyse a game. you
can also use this method to make Arena record the moves in a human vs. human game.

Having selected the engine and started a new game click on Position > Analyze Now! (or
click the Analyze button in the Moves window). This will start the engine analyzing the
position (unless an opening book is selected, in which case nothing will happen until you are
out of book) and you can makes moves on the board for both white and black.

If you now want to play the engine from the current position turn off analyze mode. You can
now make the next move or click Game > Move Now!to make the engine move.



3.4 Replaying a game

You can play through the moves of a saved game but unfortunately Arena doesn't send the
move information to the board, so you need to follow the moves on the screen too. But you
can still add and analyse variations. Get the board ready for a new game, load the PGN file
you want and put Arena into Analysis mode. You can now go through the moves using the

right-arrow key while making the moves on the board.

4. Use with CB-Emu (Arena)

CB-Emu is a program by Franz Huber that allows you to play against old chess computers
on your PC, using ROM emulations of their processors.

The Setup installation for my driver will load the files into the appropriate folder (<path>\CB-
Emu\MessChess\Arena) and you can then use your eBoard by running the Arena.exe
program from that folder.

You can also run Arena directly from the MessChess.exe program but to do this you need to
edit a file in the CB-Emu\MessChess folder. MessChess defaults to using Winboard rather
than Arena, so change this by editing GUL.INI using a text editor (like Notepad), not a word
processor (like Word). Change the first line from 1 to 2:

| GULini - Notepad

File Edit Format View Help
2

First line: GUI for MessChess

WinBoard (default)
Arena

fad =
nn

5. Use with Fritz and ChessBase

5.1 Playing an engine

Having set up the game details (engine, time etc) you can activate the board from the Board
tab. For example, in the Easy Game menu:

File Home Board Openings View Help
; Board Sounds DGT Board -@
% v Coordinates . “ - % i t
Flip 7] Amways Promote To Quesn Square Pleces Table 3D Raytraced GPU accelerated
Eoard x Board= board = raytracing (DX12) -
Board Board 2d Board 3d DGT board

For PlayChess the option to enable the DGT board is on the Server Settings screen.

The driver will then load and attempt to connect to the board. Once connected you can make
the first move or make the engine move using the Move Now button.

5.2 Different starting positions

The Fritz and ChessBase programs are written expecting the board to be a DGT, which
means they expect the board to have piece recognition. You can try using Home > Setup
Position but | found it to be extremely unreliable.



5.3 Take back moves

You can take back moves by waiting until it is you turn to move and then taking back the
computer's last move and then your own move. The LEDs on the board will lead you through
the sequence of moves. When you want to enter your replacement move just make it on the
board. Fritz automatically adds this move as a new variation so you will need to right click on
the variation and select Promote variation to make it the main line.

5.4 Analysing a game

To analyse a game or position put Fritz into Infinite Analysis mode and then make a
sequence of moves from the starting position. You can also use this method to make Fritz
record the moves in a human vs. human game.

If you now want to play the engine from the current position turn off analyze mode. You can
now make the next move or click Move Now to make the engine move.

5.5 Replaying games

You can also play through the moves of a saved game. Start a new game and get the board
ready for white's first move. Put the engine into Analysis mode and then load the game (for
example using File > Open > Open Database). You will see the moves in the game panel.
You can now play through the game using the right-arrow key, with the board's LEDs
showing the moves. You can also arrow through a set of moves and then make them all on
the board.

It is possible to enter variations using the board but | have found this to be very unreliable. It
seems to be safer to enter variation moves using the mouse on the screen while also playing
the moves on the board. To return to the main line click on the move before your variation
and my driver will prompt you to replace the pieces (this step doesn't appear to work at all
using the original DGT Rabbit plugin so it looks like ChessBase never programmed this into
their software). You can then continue playing through the game or enter another variation.

6. Use with LucasChess

In order to use my driver in LucasChess you need to tell the GUI that you have an electronic
board. This is done through the Options > Configuration screen. Go to the Boards tab and
select Novag Citrine for Digital board. (In the old LucasChess turn on Enable DGT board).

When using my board | prefer not to have the tutor popup on the screen so in the Engines
Configuration | normally go to the Tutortab and turn on Disabled at the beginning of the
game.

6.1 Playing an engine

Use the Play option to select an engine to play against. This will show you a screen where
you can select the opponent, choose the colour to play, set the time controls, specify a
starting position (see note 2.2 above) and so on. Once you have completed this click the
Accept button.

If you didn't activate the board using the option on the Play screen you can now enable it
using the button on the menu bar:
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Set up the configuration details in my driver if required, and then play the moves on the
board and they will appear on the screen in LucasChess.

To start a new game use the Cancel button and then Play again, or use Adjourn to save a
game for continuation later. If you adjourn a game where you have flipped the board (black
playing from your side) then when you resume the game you will need to set up the position
and continue without the board flipped since you can only tell the Citrine to flip the board
when it is the normal starting position.

You can deactivate and activate the board again at any time.

6.2 Take back moves

You can take back moves by waiting until it is you turn to move and then taking back the
computer's last move and then your own move. The LEDs on the board will lead you through
the sequence of moves. When you want to enter your replacement move just make it on the
board.

6.3 Analysing a game

You can play through your own game by using the Tools > Create your own game option.
Enter the moves you want, including taking back moves. To analyse a move double click on
it in the move list panel. You can also use this method to make LucasChess record the
moves in a human vs. human game.

To enter a variation right-click on the move and use the Append variation button to display
the variation screen. For this screen you cannot use the board though and must enter the
moves using the mouse.

6.4 Replaying games

You can also play through the moves of a saved game. Start a new game and get the board
ready for white's first move. Load the game using Tools > PGN > Load PGN file and you will
see the moves in the game panel. Move to the beginning of the game and enable the board.
You can now play through the game using the right-arrow key, with the board's LEDs
showing the moves. You can also arrow through a set of moves and then make them all on
the board.

If you want to enter a variation just make a different move from the one in the file and play
through the moves you want. To return to the main line take back the moves in the variation
and you can then continue playing through the game.

7. Use with Shredder

7.1 Playing an engine

When you select File > New Game you can select the strength of the opponent or you can
use Levels to set the strength and time controls.

To activate the board use Mode > External Board > DGT Board:
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Set up the configuration details in my driver if required, and then play the first move as white.
If you want to play black select Commands > Compute / Switch Sides and the computer will
make its move.

To start a new game either select File > New Game or return all the pieces to the starting
position on the board. Or use File > Edit Position (or the Edit Position button) to set up a new
starting position, but see note 2.2 above.

As with the other GUIs it is a good idea to deactivate the board before quitting the GUI.

7.2 Take back moves

If you want to take back a move wait until it is your turn to play and then take back the
moves you want on the board. The screen in Shredder will automatically be updated. When
you then make your amended move Shredder will ask if this is a new variation or if the old
moves should be overwritten.

Note that with my driver when you take back a move the Shredder clock is also rewound to
the correct time. This doesn't happen if you play with Shredder on your screen and use the
Take Back button.

7.3 Analysing a game

You can use the Mode > Analysis option to allow you to make multiple moves on the board
with the engine analysing the positions. You can also make take back moves and create
new variations, or if you want to continue playing against the engine from the current position
use Mode > Play against Computer.

7.4 Replaying a game

You can play through the moves of a saved game but unfortunately Shredder doesn't send
the move information to the board, so you need to follow the moves on the screen too. But
you can still add and analyse variations. Get the board ready for a new game, load the PGN
file you want using File > Load Game and put Shredder into Analysis mode. You can now go
through the moves using the right-arrow key while making the moves on the board.

To enter a variation just make a different move to the one in the game. Unfortunately, to
return to the main line you need to manually take back the moves in the variation before you
can then continue the game.



8. Use as a UCI or Winboard engine

For GUIs that don't support the DLL version of my driver | have also created an engine
version. This can be used in an engine vs engine game to allow you to use your board for
playing games. Some of the disadvantages of playing like this are:

1 You are not allowed to take back moves in engine matches
1 Youcan't play "rated" games

1 Opening book options might be limited

i

Time control options are often limited (it isn't always possible to give one engine more
time than the other)

The engine supports both the Winboard and UCI protocols.

My DLL driver and Winboard engine both use an INI file to store the settings, which gave me
a choice for the UCI engine. | decided to keep it the same as the other two, so the
configuration of the driver in UCI mode is controlled by the Config tab of my screen rather
than the UCI engine configuration in the GUI.

8.1 Installation

My Setup program will ask you where to install the engine file. | recommend that you create
a main folder for holding any of my eBoard engines that you want to load and that when you
"install" them into each GUI that you link to them from that folder. If you load them separately
into each GUI you will need to manually copy the files again each time | issue an update. It
also means that the eBoard will use the same INI file settings across all of the GUIs you use.

The process of installing the engine into the GUI depends on each GUI, but in general you
will need to give the engine a name and identify where the EXE file is.

8.2 Playing an engine

How you create an engine vs engine match also depends on how the GUI works. You might
find that some GUIs also start the engine during the match setup in which case my driver
screen will appear quite early.

Also, some GUIs don't close the engine when an engine match is finished so you might need
to either start a different match or use the "Close engine" option in the GUI to close my driver
screen.

9. Use with SCIDvsPC

Although SCIDvsPC uses the UCI engine version of my driver it has been amended to allow
for take back moves and so on. It is used by adding it as a secondary Analysis engine rather
than the main engine in a computer vs computer match.

9.1 Installation

Having installed the driver file using the Setup program (probably to a common folder for all
GUIs to share) you must then install it as an engine in SCIDvsPC. Go to Tools > Analysis
engines:



& Analysis Engines = o -

Analysis Engines

Hame Eey TIype Elc Date

Stockfish F2 uci 3300 31/01/201% ﬂ
Toga F3 uci 2800 15/04/2013

Phalanx XXIV xboard 2200 2471272014

Scidlet xboard 07/02/2018

eBoard NUT uci 12/01/2023

=~
4}| ﬂ| ‘ %| Edit ‘ -------- New Copy ‘ Delete |

[~ Info [ Board Board Size |2 il W Show Arrows W Low CPU Priority W Add Name

Log Size 5000 Max Ply |0 jl [~ Wrap Long Lines Start | Close |

Use the New button to add an engine. Give it a name, select the engine file and make sure it
is set to use UCI as the protocol:

ﬁ Configure Engine — (=] -

Name eBoard MUT

Command |D:/eBoards/MUT_ENG exe Browse

Directory | ; scid_exe |:|ir|
Parameters

Webpage Open

Elo 0

Protocol f¥ UCI " Xboard Configure

HotkKey " F2  F3  F4 1 none

Fields in bold are required; others are optional

OK Help Cancel

Click Ok when done.

9.2 Playing an engine

Before starting a game go into the Analysis engines screen (Tools > Analysis engines),
select the eBoard you want and click Start. The driver will load and connect to your board.

Now you can start a normal game using Play > Computer UCI engine or Play > Internet
(FICS). To play black use the Flip board button. Moves made on the eBoard will
automatically be made on the screen so that the engine can reply.

You can take back moves during a game. Wait until it is your turn to move then take back

the computer's move and your own. When you have finished taking back moves click on the
Resume button to continue playing.

You can also enter a game or record the moves of a human vs human game by using Game
> New game and entering the moves on the eBoard.



10. Legal stuff

This software is distributed in the hope that it will be useful, but WITHOUT ANY
WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A

PARTICULAR PURPOSE.
Copyright (C) 2021-2024 Graham O'Neill [https://goneill.co.nz/chess]

Piece graphics: By Wikipedia user Cburnett, via Wikimedia Commons
[CC BY-SA 3.0 (http://creativecommons.org/licenses/by-sa/3.0)]



